Home

Rich Internet Applications offer a rich engaging user experience in a single page.
They employ an intelligent client engine that asynchronously fetches and updates data based on user interaction and also determines how the data will be displayed. This reduces the amount and frequency of client-server traffic and thereby results in greater responsiveness than traditional page-based Content Management Systems (CMS).


RIAmore: cross-platform rich internet applications

RIAmore develops cross-platform rich internet applications for Android, web and desktop written in the open source programming languages ActionScript and Dart.
ActionScript Applications use the Flash Runtime (1) as an intelligent client engine.
Dart applications are compiled to Javascript and run without any plugin on modern browsers (2) or as hybrid applications with the help of wrapper-software (Apache Cordova or the Intel open-source project Crosswalk).

Frameworks and UI components

RIAmore uses the following frameworks and components:

  • Apache Flex open source application framework;
  • Starling open source GPU accelerated framework for ActionScript 3;
  • Feathers open source user interface components for Starling framework;
  • StageXL for Dart an open source Flash-like framework built op top of the Dart programming language,
    it uses the HTML5 Canvas element and offers WebGL support.

Client server communication

RIAmore uses the Adobe Messaging Format (AMF) and JSON as gateways between client and server.
On the server side PHP (Zend Framework) is used.


(1) Apache Flex and Adobe Flash applications require the cross-platform Adobe Flash® Player that is installed on more than 94% of all PCs and laptops across the world. Adobe AIR applications require the cross-platform Adobe Integrated Runtime (AIR) environment. (back)

(2) Dart is supported on modern browsers:

  • Internet Explorer, versions 9, 10, and 11 (Dart v1.5 will be the last release to support Internet Explorer 9);
  • Firefox, latest version;
  • Chrome, latest version;
  • Safari for desktop, version 6;
  • Safari for mobile, version 6. (back)

Source: https://www.dartlang.org/support/faq.html#q-what-browsers-do-you-support-as-javascript-compilation-targets